Java Int to String - Hacker Rank Solution

Java Int to String - Hacker Rank Solution

Hello Friends, How are you? Today I will solve the HackerRank Java Int to String Problem with a very easy explanation. This is the 11th problem of Java on HackerRank. So let's start-

Java Int to String - Hacker Rank Solution


Table of Content (toc)

HackerRank Java Int to String - Problem Statement

You are given an integer n, you have to convert it into a string.

Please complete the partially completed code in the editor. If your code successfully converts n into a string s the code will print "Good job". Otherwise, it will print "Wrong answer".

n can range between -100 to 100 inclusive.

Sample Input:

100 (code-box)

Sample Output:

Good job (code-box)

Java Int to String - Hacker Rank Solution

Approach I:


import java.util.*;
import java.security.*;
public class Solution {
 public static void main(String[] args) {

  DoNotTerminate.forbidExit();

  try {
   Scanner in = new Scanner(System.in);
   int n = in .nextInt();
   in.close();
   //String s=???; Complete this line below

   String s = "" + n;

   
   if (n == Integer.parseInt(s)) {
    System.out.println("Good job");
   } else {
    System.out.println("Wrong answer.");
   }
  } catch (DoNotTerminate.ExitTrappedException e) {
   System.out.println("Unsuccessful Termination!!");
  }
 }
}

//The following class will prevent you from terminating the code using exit(0)!
class DoNotTerminate {

 public static class ExitTrappedException extends SecurityException {

  private static final long serialVersionUID = 1;
 }

 public static void forbidExit() {
  final SecurityManager securityManager = new SecurityManager() {
   @Override
   public void checkPermission(Permission permission) {
    if (permission.getName().contains("exitVM")) {
     throw new ExitTrappedException();
    }
   }
  };
  System.setSecurityManager(securityManager);
 }
}


Disclaimer: The above Problem ( Java Int to String ) is generated by Hackerrank but the Solution is Provided by Code Solution. This tutorial is only for Educational and Learning purposes. Authority if any queries regarding this post or website fill out the contact form.

I hope you have understood the solution to this HackerRank Problem. The above solution will pass all the test cases. Now visit Java Int to String HackerRank Problem and try to solve it again.

All the Best!

Post a Comment

0 Comments
* Please Don't Spam Here. All the Comments are Reviewed by Admin.