Java Output Formatting – Hacker Rank Solution

Java Output Formatting – Hacker Rank Solution

Hello Friends, How are you? Today I will solve the HackerRank Java Output Formatting Problem with a very easy explanation. This is the 5th problem of Java on HackerRank. In this article, you will get more than three approaches to solving this problem. So let's start-

Java Output Formatting – Hacker Rank Solution


Table of Content (toc)

Hacker Rank Java Output Formatting - Problem Statement

Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.

To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.

Input Format

Every line of input will contain a String followed by an integer.
Each String will have a maximum of 10 alphabetic characters, and each integer will be in the inclusive range from 0 to 999.

Output Format

In each line of output there should be two columns:
The first column contains the String and is left-justified using exactly 15 characters.
The second column contains the integer, expressed in exactly 3 digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.


Sample Input:

java 100 cpp 65 python 50 (code-box)

Sample Output:

================================ java 100 cpp 065 python 050 ================================ (code-box)

Explanation

Each String is left-justified with trailing whitespace through the first 15 characters. The leading digit of the integer is the 16th character, and each integer that was less than 3 digits now has leading zeroes.

Java Output Formatting – Hacker Rank Solution

Approach I:

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);

            System.out.println("================================");
            for(int i=0;i<3;i++){
                String s1=sc.next();
                int x=sc.nextInt();
                System.out.printf("%-15s", s1);
                System.out.printf("%03d%n", x );
            }
            System.out.println("================================");

    }
}


Approach II:

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);
            System.out.println("================================");
            for(int i=0;i<3;i++)
            {
                String s1=sc.next();
                int x=sc.nextInt();
                System.out.printf("%-15s%03d%n",s1,x);
            }
            System.out.println("================================");

    }
}


Approach III:

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);
            System.out.println("================================");
            for(int i=0;i<3;i++)
            {
                String s1=sc.next();
                int x=sc.nextInt();
                System.out.printf("%-15s%03d%n", s1, x);
            }
            System.out.println("================================");

    }
}


Approach IV:

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);
            System.out.println("================================");
            for(int i=0;i<3;i++)
            {
                String s1=sc.next();
                int x=sc.nextInt();
                System.out.printf("%-15s%03d%n", s1, x); 
            }
            System.out.println("================================");

    }
}

Disclaimer: The above Problem ( Java Output Formatting ) is generated by Hackerrank but the Solution is Provided by Code Solution. This tutorial is only for Educational and Learning purposes. Authority if any queries regarding this post or website fill out the contact form.

I hope you have understood the solution to this HackerRank Problem. All these four solutions will pass all the test cases. Now visit Java Output Formatting HackerRank Problem and try to solve it again.

All the Best!

Post a Comment

2 Comments
* Please Don't Spam Here. All the Comments are Reviewed by Admin.